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New installation: SAP no object found

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First published by:
Yujira
on 20 Oct 2010
Last revision by:
Yujira
on 24 Jun 2011
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New installation: SAP no object found

 

Symptoms

When first attempting to execute a process against the SAP GUI, the process aborts for some Certify clients while other Certify clients work fine.  The Certify log-file.txt file (found in {User folder}\Application Data\Worksoft) indicates "No Object", even though users were able to LiveTouch the objects correctly indicating that the Certify map contains the correct object definition. The error message shown is "wsSAP.dll not found."

 

Root Cause

This issue usually occurs due to an incomplete or improper installation of Certify when the SAP Interface's SAPDispatcherProxy.dll is not registered properly.

 

Solution

To resolve this issue, please follow these steps:

1. Download the SAPDispatcherProxy.abc registry file to the local machine exhibiting the problem.
(NOTE: The extension of the file has been changed to prevent the file from being blocked when downloaded.)

2. Rename SAPDispatcherProxy.abc  to SAPDispatcherProxy.reg.

3. If Certify is installed in the default location (C:\Program Files\Worksoft\Certify), execute SAPDispatcherProxy.reg by double clicking on it.  Otherwise, open the SAPDispatcherProxy.reg file in Notepad, modify every file location reference to point to the correct Certify installation location, then Save the file and execute it.

 

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